GIMP 2.10

How tos

Apply transparent background in GIMP

  1. Select Layer → Transparency → Add Alpha Channel
  2. Select the background using the Fuzzy Selection Tool (Magic Wand) and press the Del key.

GIF will allow you single-color transparency, while PNG has full alpha channel support.
See also GIMP Watermark removal

Change color of text within selection

  1. Select layer with color area to be changed, Select –> All, select this color area with the Fuzzy Select Tool, Select –> Invert.
  2. Select layer with text and click text within color area, this should result in selection around text within color area. Make layer with color area invisible.
  3. Click Select –> Selection Editor, set Opacity to 100, Threshold to 80 (normal font weight) or 120 (bold), Fill by to Alpha, and enable Antialiasing. Shrink the selection by 1px in Select –> Shrink.
  4. Select Bucket Fill Tool, choose foreground color, and click on each letter within the color area.

Text along path

  1. Select a path with the Fuzzy Select Tool
  2. Select menu Select → To Path
  3. Select the Flip Tool
  4. Select Affect: Path and Flip Type: Vertical
  5. Click into the layer with the selection to flip the path
  6. Select the Text Tool and type the text
  7. Right click into the text box and select Text along Path
  8. Select menu Layer → New Layer
  9. Select Path to Selection in window Paths - Brushes / Open the paths dialog
  10. Select the Pencil Tool and paint the text
  11. Select menu Layer → Transform → Arbitrary Rotation, set the center point, and rotate the text
  12. Right click on the temporary layer Floating Selection in window Layers - Brushes and select To new Layer
  13. Delete any layers not needed anymore

This is for text along a circle in the bottom of the circle. For the text on top of the circle, omit steps 3-5.

Alternate text along path

  • Create selection, for example a circle, then select Selection to path.
  • Invert the selection if the text needs to follow /\ instead of \/. Select Invert and click next to the path.
  • Write the text and select Text along path.
  • Create new layer and select Path to selection. Hide other layers and fill the selection with color.

Remove background

  1. Right-click on the layer, select Layers –> Add Alpha Channel
  2. Right-click on the layer, select Layers –> Duplicate Layer (not necessary, just to be save to have a backup)
  3. Make copy visible only, then Select All, then select the Fuzzy Select Tool and click into the background area
  4. Select Selection to path, and again Path to selection, and make the path visible
  5. Right-click on the layer, select Add Layer Mask…, choose Selection and click Add
  6. Go to Image –> Fit Canvas to Selection, and save

Plugins

Resynthesizer

Resynthesizer allows you to remove watermarks and similar from an image. Download it from the GIMP Plugin Registry or my wiki. Move all files to GIMPPortable\Data\.gimp\plug-ins\.

Tutorials