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Heracles

Hardware

Original purchase 06.2025, assembled 08.2025, serving as Hua Hin Desktop on Windows 11
Professional.

e CPU: AMD Ryzen 9 9950X3D (16 cores - 32 threads)

e Cooler: Thermalright Peerless Assassin 120 Digital ARGB Black

e System Memory: 128GB (2x64GB) Crucial Pro DDR5 5600MHz (CP2K64G56C46U5) System
Memory

e System Drive: Corsair Force MP510

System Drive: Corsair Force MP510, 960GB NVMe M.2 Gen3 x4

Data Drive 1: Crucial T700, 4TB NVMe M.2 Gen5 x4

Data Drive 2: Crucial P310, 4TB NVMe M.2 Gen4 x4

Motherboard: MSI MPG X870E Carbon Wifi

Graphics: Powercolor Radeon RX 970 XT OC Red Devil

e Optical drive 1: Samsung 16x Blue-Ray / DVD Writer (BH16NS40) (taken from Hercules)

e Optical drive 2: Pioneer BDXL UltraHD Blue-Ray Reader (BH16NS40) (taken from Hercules)

e Case: Thermaltake Suppressor F51 with custom USB-C front header (taken from Olympus)

e Power: Be Quiet! Power Zone 2 1000W

2018/02/27 00:36 - Bernard Condrau
ASRock X870E Taichi Lite

I made this description to document my install attempts with a broken ASRock X870E Taichi Lite
motherboard

BIOS Settings

Upgrade to BIOS 3.25 or higher (BIOS 3.40 as of 1/09/2025)

Advanced -> PCI Configuration: Re-Size BAR Support

Advanced -> PCI Configuration: SR-IOV Support

Advanced -> ACPI Configuration: PCIE Devices Power On

Advanced -> AMD CBS -> NBIO Common Options -> GFX Configuration:

Advanced -> AMD CBS -> NBIO Common Options -> Audio Configuration: NB Azalia
Advanced -> AMD PBS -> AMD Common Platform Module: PCle/GFX Lanes Configuration
Advanced -> AMD PBS -> AMD Common Platform Module: PCle x16 Link Speed
H/W Monitor:

Security:

Boot:

HOWONOU AWNDE
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These are the BIOS settings of interest for me, color indicates settings modified from default
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Setup (Windows 11 fresh install)

If you are transferring a Windows 10 or 11 license from another computer | suggest to go through the
Windows 11 install procedure twice. The following guide explains how and why. AMD graphic cards
sometimes face issues with driver version when installed on an AMD motherboard.

First install

1.

&

If moving a license from an old pc: make sure your license shows as Windows is activated with a
digital license linked to your Microsoft account on your old pc. If it's not you need to login to
your Microsoft account to register your device.
Download Windows 11 by downloading the latest Windows version as ISO file (do not create the
media from the download page). Starting with Windows 11 v24H2 the default installation media
of Windows 11 automatically activates BitLocker and encrypts your drives. To prevent this, do
the following:

o Create the USB drive with Rufus Standard or Portable version

o Customize the install media after clicking the [Start] button

o If you have not followed these steps and have your drives already encrypted, enter the
following commands in PowerShell run as administrator

$BLV = Get-BitLockerVolume
Disable-BitLocker -MountPoint $BLV

o After having decrypted all drives run Services and set the BitLocker Drive Encryption
Startup Type to disabled

o You must make sure BitLocker is off on all drives before updating the BIOS!
Restart your computer and install Windows 11 from USB stick
On the Continue to Signin screen enter your email address and sign in to your Microsoft account
After the boot is complete verify that your license shows as Windows is activated with a digital
license linked to your Microsoft account
For a graphic card install Powercolor Keystone. Start Keystone and
enable “Sync RGB with motherboard”. The card keeps the setting, so you can uninstall the
Keystone software after having made the settings change or if you follow with Second install
below, you don't need to install Keystone again.

Second install

LN E

Make sure you have followed the steps as set out in First install above
Restart your computer and install Windows 11 from USB stick
Disconnect your network card from the internet
On the Connect to the internet or Continue to Signin screen do the following to create a local
user without Microsoft account:
1. Hit Shift-F10 to open a command prompt
2. Enter start ms-cxh:localonly in the command prompt, then add the user
credentials for a local administrator
3. After that the installation process will automatically continue (see How to Install and Log
In to Windows 11 Without a Microsoft Account)

Bernard's Wiki - https://wiki.condrau.com/


https://www.microsoft.com/en-us/software-download/windows11
https://rufus.ie/en/
https://www.powercolor.com/download24.htm
https://www.tomshardware.com/how-to/install-windows-11-without-microsoft-account
https://www.tomshardware.com/how-to/install-windows-11-without-microsoft-account

2025/09/11 02:05 3/7 Heracles

5.

[

12.
13.

14,

15.

16.
17.
18.
19.

20.

21.
22.
23.
24,
25.
26.

27.
28.

29.

= O Lo

‘Windows 11 Pro or Enterprise: open the Group Policy Editor and navigate to Computer
Configuration -> Administrative Templates -> Windows Components -> Windows Update ->
Manage updates offered from Windows Update. Enable Do not include drivers with Windows
Update.
*Windows 11 Home: Right-click the Start Menu, select System, select Advanced system settings
below Device specifications and Frequently asked questions, choose Hardware tab, then select
Device Installation Settings. Say No to Do you want to automatically download manufacturers'
apps for your devices?
Verify BitLocker is disabled as explained in First install above
Install AMD Chipset Drivers 7.06.24.2226 from ASRock or from AMD
Install AMD Software: Adrenalin Edition 25.8.1 from AMD or from ASRock
Restart your computer and ‘connect network
If you have enabled the Auto Driver Installer in BIOS the installer will automatically start on first
logon. All of the following drivers need to be installed, download missing drivers after Auto
Driver Installer from ASRock Download or from AMD.

1. MediaTek Bluetooth 1.1043.0.550

2. MediaTek WLAN 5.6.0.4261

3. Realtek USB Audio 6.4.0.2395 (optional)

4. Realtek LAN 10.074.0205.2025 (optional, Windows installs an earlier version)
Install ASRock Restart to UEFI 1.0.15 1.0.15
Auto logon: modify the following key in the registry to a value of 0, then run netplwiz and
disable Users must enter a user name and password to use this computer

HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\PasswordLess\Device\DevicePasswordLessBuildVersion

Change the power plan in Control Panel -> Power Options. First select Show additional plans,
then select High performance, go to Edit Plan Settings -> Change advanced power settings and
set USB selective suspend setting to Disabled.
Change work group in Network Adapter Settings. To do this, type “Workgroup” into the search
field at the top left of the Settings app and then click on “Change workgroup name”
Right-click on desktop, then select View -> Medium icons
Right-click on the taskbar, choose Taskbar behaviors -> Taskbar alignment
Go to Settings -> Personalisation -> Themes and select Desktop icon settings
Go to Settings -> Personalisation -> Lock screen -> Screen timeout and select Screen, sleep &
hibernate time-outs
Change to full context menu with this

Registry Key
update file
Rearrange the drive letters (right-click on Start -> Disk Managment)
Install USBDLM 5.7.3 to Manage USB Drives and bco specific Manage USB Drives
Set Open each folder in its own window in File Explorer -> 3 dots at the center top -> Options
Show file name extensions in File Explorer -> View -> Show -> File name extensions
Show hidden files in File Explorer -> View -> Show -> Hidden items
Set Switzerland in Settings -> Time & language -> Language & region -> Country or region
and English (Switzerland) in Settings -> Time & language -> Language & region ->
Regional format
Map network drives in File Explorer -> 3 dots at the center top -> Map network drive
Right-click on image and Set as desktop background, then right-click on desktop and select
Span in Personalise -> Background -> Choose a fit for your desktop image
Import Unmount and Mount tasks in Task Scheduler
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30.

31.

32.
33.

Move Documents, Pictures, Music, and Videos to new location by selecting the folder and
modifying the Location within Properties

Enable Windows Subsystem for Linux in Control Panel -> Programs and Features -> Turn
Windows features on or off

Setup access for BackupPC

Install Crucial Storage Executive

Follow these steps to avoid trouble installing display drivers

Ressources

AMD Driver Timeout Error

How To Disable Driver Install Automatically From The Windows Update

How to Restore a Missing "Users Must Enter a User Name and Password" Option in Windows 11
How to Remove ANY Virus from Windows in ONE STEP ...

GetMyDrivers

Installation Permanent

Ll

HOWwWo N WL
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Install PassMark PerformanceTest 11.1

Install Snagit 2018. Update to version 2018.2.6 within app.

Install TRCC 2.0.4 LED screen control software

Install Google Chrome. Set “Developer mode” in Extensions. Add-ons: Adobe Acrobat, Group
Speed Dial, DevTools z-index, ScriptSafe, IP Domain Country Flag, Search and Replace, User-
Agent Switcher for Chrome, GoFullPage

When prompted download and install Logitech Options+

Install VeraCrypt 1.26.24 (x64)

Install Notepad++ 8.8.5

Install Libreoffice 25.8.1.1

Install TrayStatus Pro 5.0 and enable “Show Hard Drive Activity” in “Status Indicators”
Install EaseUS Partition Master 18.2

Install EaseUS Todo Backup Home 2024

Installation Portable

1.
2.

Download GPU-Z 2.68.0
Install Revo Uninstaller. Select Download and install the Free Portable or Pro Portable version.

Not (yet) installed or checked

ok wnNe

Install AMD Software: Adrenalin Edition 25.3.1 from Powercolor
SMPlayer

iVMS-4200

VirtualBox

Install Hearthstone.

Install FlexHEX 2.6

Bernard's Wiki - https://wiki.condrau.com/


https://wiki.condrau.com/deb11:backuppc#configuration_on_hosts_without_fixed_ip_address_behind_a_firewall
https://www.crucial.com/support/storage-executive
https://windowsreport.com/amd-driver-timeout/
https://www.youtube.com/watch?v=-wIsmrWWTHk&t=78s
https://www.makeuseof.com/windows-11-missing-auto-login-fix/
https://www.youtube.com/watch?v=Rf1Y5o9FogA
https://www.getmydrivers.com
https://www.passmark.com/products/performancetest/download.php
https://www.techsmith.com/snagit.html
https://thermalright.com/support/download/
https://www.google.com/chrome/
https://www.logitech.com/en-us/software/logi-options-plus.html?modalclick=options
https://veracrypt.codeplex.com//
https://notepad-plus-plus.org/
https://www.libreoffice.org/
https://www.traystatus.com/
https://www.easeus.com/
https://www.easeus.com/
https://www.techpowerup.com/gpuz/
https://www.revouninstaller.com/
https://www.powercolor.com/download.htm
https://www.powercolor.com/download.htm
https://us.battle.net/account/download/
http://www.flexhex.com/

2025/09/11 02:05

5/7

Heracles

10.
11.
12.
13.
14,
15.
16.
17.
18.
19.
20.
21.
22.
23.
24,
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.

. Install Foxit PDF Reader
. Install the Logitech Harmony Software
. Install APC PowerChute Business Edition 9.2. If you control the UPS through Linux, install the

agent only. The agent runs as a service, you can set it's startup to manual, and run it only when

you need to change settings.

Install Oracle VM Virtualbox 5.1.30

Install PDF Booklet

Install Roadkil's Disk Image 1.6 to PortableCustom
Install tiny media manager to PortableCustom

Install Prey.

Install Zoom

Install Safari 5.1.7.

Install Garmin Express.

Install Sunny Explorer 1.07.29.R.
Install PDFsam Basic.

Install Synology Photo Station Uploader 091

BlueStacks
XLaunch

Youtube

Garmin

FoscamVMS
ClickMonitor

HTTP Toolkit
Amlogic Burn Tool
USB Burning Tool
Ashampoo pdf free
Ashampoo photo commander 17
HTTP Toolkit 1.5.1
Hearthstone
Battle.net

FileZilla Server 1.20
FoscamVMS
Attribute Changer 9.50a
Reolink 8.7.1
Sunny Explorer
Steam

Synology Assistant
Google Calendar
Hermes Calendar
VcXsrv

Zattoo

Zoom

WinPcap 4.1.3
PhoenixSuit

Pale Moon 32.3.1
MyHarmony

MySQL Workbench 8.0.15
iVMS-4200
Hardwipe 5.2.1
GIMP 2.10

devolo Cockpit
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56.
57.
58.
59.
60.
61.
62.

Album Art Downloader XUI 1.05
D-Link Network Assistant
OpenVPN Connect

Vim 8.1

Rasperry Pi Imager

Node.js

PDFsam Basic

HW Transfer

Hercules -> Olympus2

Ll

9.

Check Hercules hardware with Debian 9 live system
Run PassMark benchmark
Register machine in Microsoft account
Remove hardware from Hercules
o BD Drive
o UHD Drive
o Power Supply
o Graphic Card
o All drives

. Transfer hardware from Olympus

o Power Supply
o Data drives
o Graphic Card
New hardware
o System drives
Boot Olympus2 on new hardware and check

. Remove hardware from Olympus to bring to Flims

o Motherboard
o DRAM
o CPU + Cooler
Copy/move F: drive from HDD to SSD (particularly F:\games)

Olympus -> Hestia2

1.
2.

Check Olympus hardware with Debian 11 live system
Remove hardware from Hestia

Setup (Windows 10 to 11 upgrade)

. Disable Fast Boot in BIOS
. Make sure your license shows as Windows is activated with a digital license linked to your

Microsoft account

Go to Windows Update and download and install Windows 11
Remove old graphics drivers in case you changed your graphics card:

1. Download Display Driver Uninstaller (DDU) v18.1.3.0 and save it to a local hard drive
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12.

13.
14,
15.
16.
17.

2. Hold SHIFT and select restart Windows
Keep holding SHIFT until the Recovery Partition Menu shows up
Go to Troubleshoot -> Advanced options -> Startup Settings and click Restart
Once in the Startup Settings select 4) Enable Safe Mode with network disabled
Once Windows has started in Safe Mode run DDU
7. Reboot into Windows after DDU has completed
Remove unused apps like CorsairLink, Hardwipe, etc.
Auto logon: modify or create the following key in the registry to a value of 0, then run netplwiz
and disable Users must enter a user name and password to use this computer

o v W

HKEY LOCAL MACHINE\SOFTWARE\Microsoft\Windows
NT\CurrentVersion\PasswordLess\Device\DevicePasswordLessBuildVersion

Create local user with the same username (bco), assigh Administrator permissions and log in

. Change work group in Network Adapter Settings. To do this, type “Workgroup” into the search

field at the top left of the Settings app and then click on “Change workgroup name”

. Right-click on desktop, then select View -> Medium icons
10.
11.

Right-click on the taskbar, choose Taskbar behaviors -> Taskbar alignment
Uninstall Corsair Link 4, Parallels Access and other apps with Revo Uninstaller. Select Download
and install the Free Portable or Pro Portable version.
Change to full context menu with this

Registry Key
update file
Set Open each folder in its own window in File Explorer -> 3 dots at the center top -> Options
Show file name extensions in File Explorer -> View -> Show -> File name extensions
Show hidden files in File Explorer -> View -> Show -> Hidden items
Map network drives in File Explorer -> 3 dots at the center top -> Map network drive
Right-click on image and Set as desktop background, then right-click on desktop and select
Span in Personalise -> Background -> Choose a fit for your desktop image

e How to Restore a Missing "Users Must Enter a User Name and Password" Option in Windows 11
e How to Remove ANY Virus from Windows in ONE STEP ...
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